Missing Utility Rates on Energy Usage Page

Incident Report for Aurora Solar

Resolved

This issue has been resolved.
Posted Aug 31, 2026 - 11:17 PDT

Monitoring

We have implemented a rollback to address this issue and are seeing rates populate as expected. We are continuing to monitor the situation. Thank you!
Posted Aug 31, 2026 - 07:38 PDT

Investigating

We are experiencing an issue where utility rates are not populating on the Energy Usage page. Our Engineering teams are investigating the issue, and we will provide an update as soon as possible.
Posted Aug 31, 2026 - 07:21 PDT
This incident affected: Aurora Solar App.