Our engineering team is actively monitoring the recovery phase, and we’ll provide updates as soon as we have further details.
Posted Oct 20, 2025 - 12:22 PDT
Monitoring
Our third-party provider has reported progress in resolving the underlying infrastructure issue affecting their services. Early signs of recovery are being observed, and they're seeing improvements as a result. Our team continues to monitor the situation closely and will provide further updates once full service stability is confirmed.
Posted Oct 20, 2025 - 10:43 PDT
Update
The third-party issue is showing progress toward resolution. Our Engineering Team continues to monitor the situation and will provide an update once the service has been fully restored.
Posted Oct 20, 2025 - 09:12 PDT
Update
We’ve identified the issue as a third-party outage. Our Engineering Team is working on a fix, and we’ll share updates as soon as more information is available.
Posted Oct 20, 2025 - 08:09 PDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 08:08 PDT
Identified
We’ve identified the issue as a third-party outage. Our Engineering Team is working on a fix, and we’ll share updates as soon as more information is available.
Posted Oct 20, 2025 - 07:38 PDT
Investigating
Currently, we are experiencing an issue where our users are having issues loading the Aurora App. Our Engineering teams are investigating and we will provide an update as soon as possible.
Posted Oct 20, 2025 - 06:53 PDT
This incident affected: Aurora Solar App, Aurora Simulations, Aurora API, Sales Mode, Design Mode, Financing Integrations, Plan Sets, and Design Services.